CONFIG(5) | File Formats Manual | CONFIG(5) |
config
— kernel
configuration file format
A kernel configuration file specifies the configuration of a FreeBSD kernel. It is processed by config(8) to create a build environment where a kernel may be built using make(1).
A kernel configuration file comprises a sequence of specification directives.
A specification directive starts with a keyword at the beginning of the line and is followed by additional parameters.
A specification directive may be terminated by a semicolon
‘;
’ or by a newline. Long input lines
may be broken into shorter lines by starting the second and subsequent lines
with a white space character.
Case is significant,
“machine
” and
“MACHINE
” are different tokens.
A double quote character
‘"
’ starts a quoted string. All
characters up to the next quote character form the value of the quoted
string. A ‘"
’ character may be
inserted into a quoted string by using the sequence
‘\"
’.
Numbers are specified using C-style syntax.
A ‘#
’ character starts a
comment; all characters from the ‘#
’
character till the end of the current line are ignored.
Whitespace between tokens is ignored, except inside quoted strings. Whitespace following a comment line is ignored.
Kernel configuration directives may appear in any order in a kernel configuration file. Directives are processed in order of appearance with subsequent directive lines overriding the effect of prior ones.
The list of keywords and their meanings are as follows:
cpu
cputypecpu
directive in a configuration file. The allowed
list of CPU names is architecture specific and is defined in the file
sys/conf/options.⟨arch⟩.
device
name [, name [...]]devices
name [, name [...]]env
filenameThis directive is useful for setting kernel tunables in embedded environments that do not start from loader(8).
files
filenamehints
filenameident
nameident
directive is required.
include
filenamemachine
arch [cpuarch]alpha
arm
amd64
i386
ia64
mips
pc98
powerpc
sparc64
If argument cpuarch is specified, it
points config(8) to the cpu architecture of the
machine. Currently the pc98
architecture
requires its cpu architecture to be set to i386
.
When cpuarch is not specified, it is assumed to be
the same as arch. arch
corresponds to MACHINE. cpuarch corresponds to
MACHINE_ARCH.
A kernel configuration file may have only one
machine
directive.
makeoption
optionsmakeoptions
optionsThe options argument is a comma separated list of one or more option specifications. Each option specification has the form
and results in the appropriate make(1) variable definition being inserted into the generated makefile. If only the name of the make(1) variable is specified, value is assumed to be the empty string.
Example:
makeoptions MYMAKEOPTION="foo" makeoptions MYMAKEOPTION+="bar" makeoptions MYNULLMAKEOPTION
maxusers
numberAs explained in tuning(7), this tunable can also be set at boot time using loader(8).
nocpu
cputypecpu
directives in files included using include
.
nodevice
name [, name [...]]nodevices
name [, name [...]]device
or devices
directives in files included using include
.
nomakeoption
namenomakeoptions
namemakeoption
directives in files included using include
.
nooption
name [, name [...]]nooptions
name [, name [...]]option
or options
directives in files included using include
.
option
optionspec [, optionspec
[...]]options
optionspec [, optionspec
[...]]If value is not specified, it is assumed
to be NULL
. Options common to all architectures
are specified in the file sys/conf/options.
Options specific to architecture arch are
specified in the file
sys/conf/options.⟨arch⟩.
profile
number-p
option to config(8).The following kernel configuration directives are obsolete.
kenv(1), make(1), device.hints(5), loader.conf(5), config(8), kldload(8), loader(8)
Samuel J. Leffler and Michael J. Karels, Building 4.4BSD Kernels with Config.
The config(8) utility first appeared in 4.1BSD, and was subsequently revised in 4.4BSD.
The kernel configuration mechanism changed further in FreeBSD 4.0 and FreeBSD 5.0, moving toward an architecture supporting dynamic kernel configuration.
December 3, 2005 | Debian |