DOKK / manpages / debian 10 / freebsd-manpages / BUS_CHILD_DELETED.9freebsd.en
BUS_CHILD_DELETED(9) Kernel Developer's Manual BUS_CHILD_DELETED(9)

BUS_CHILD_DELETEDnotify a bus device that a child is being deleted

#include <sys/param.h>
#include <sys/bus.h>

void
BUS_CHILD_DELETED(device_t dev, device_t child);

The () method is invoked by the new-bus framework when a device is deleted. A bus driver can provide an implementation of this method to release bus-specific resources associated with a device such as instance variables.

BUS_ADD_CHILD(9), device(9)

The BUS_CHILD_DELETED() method first appeared in FreeBSD 10.0.

August 21, 2012 Debian