BUS_GET_CPUS(9) | Kernel Developer's Manual | BUS_GET_CPUS(9) |
BUS_GET_CPUS
,
bus_get_cpus
— request a set
of device-specific CPUs
#include
<sys/param.h>
#include <sys/bus.h>
#include <sys/cpuset.h>
int
BUS_GET_CPUS
(device_t dev,
device_t child, enum cpu_sets
op, size_t setsize, cpuset_t
*cpuset);
int
bus_get_cpus
(device_t dev,
enum cpu_sets op, size_t
setsize, cpuset_t *cpuset);
The
BUS_GET_CPUS
()
method queries the parent bus device for a set of device-specific CPUs. The
op argument specifies which set of CPUs to retrieve.
If successful, the requested set of CPUs are returned in
cpuset. The setsize argument
specifies the size in bytes of the set passed in
cpuset.
BUS_GET_CPUS
()
supports querying different types of CPU sets via the op
argument. Not all set types are supported for every device. If a set
type is not supported, BUS_GET_CPUS
() fails with
EINVAL
. These set types are supported:
LOCAL_CPUS
INTR_CPUS
The
bus_get_cpus
()
function is a simple wrapper around
BUS_GET_CPUS
().
Zero is returned on success, otherwise an appropriate error is returned.
The BUS_GET_CPUS
() method and
bus_get_cpus
() function first appeared in
FreeBSD 11.0.
March 1, 2016 | Debian |