AHCI(4) | Device Drivers Manual | AHCI(4) |
ahci
— Serial ATA
Advanced Host Controller Interface driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device pci
device scbus
device ahci
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
ahci_load="YES"
The following tunables are settable from the loader(8):
Some controllers, such as ICH8, do not implement modes 2 and 3 with NCQ used. Because of artificial entering latency, performance degradation in modes 4 and 5 is much smaller then in modes 2 and 3.
Note that interface Power Management complicates device presence detection. A manual bus reset/rescan may be needed after device hot-plug, unless hardware implements Cold Presence Detection.
This driver provides the CAM(4) subsystem with native access to the SATA ports of AHCI-compatible controllers. Each SATA port found is represented to CAM as a separate bus with one target, or, if HBA supports Port Multipliers, 16 targets. Most of the bus-management details are handled by the SATA-specific transport of CAM. Connected ATA disks are handled by the ATA protocol disk peripheral driver ada(4). ATAPI devices are handled by the SCSI protocol peripheral drivers cd(4), da(4), sa(4), etc.
Driver features include support for Serial ATA and ATAPI devices, Port Multipliers (including FIS-based switching, when supported), hardware command queues (up to 32 commands per port), Native Command Queuing, SATA interface Power Management, device hot-plug and Message Signaled Interrupts.
Driver supports "LED" enclosure management messages, defined by the AHCI. When supported by hardware, it allows to control per-port activity, locate and fault LEDs via the led(4) API or emulated ses(4) device for localization and status reporting purposes. Supporting AHCI controllers may transmit that information to the backplane controllers via SGPIO interface. Backplane controllers interpret received statuses in some way (IBPI standard) to report them using present indicators.
The ahci
driver supports AHCI compatible
controllers having PCI class 1 (mass storage), subclass 6 (SATA) and
programming interface 1 (AHCI).
Also, in cooperation with atamarvell and atajmicron drivers of ata(4), it supports AHCI part of legacy-PATA + AHCI-SATA combined controllers, such as JMicron JMB36x and Marvell 88SE61xx.
The ahci
driver first appeared in
FreeBSD 8.0.
Alexander Motin <mav@FreeBSD.org>
October 22, 2013 | Debian |