DC(4) | Device Drivers Manual | DC(4) |
dc
— DEC/Intel
21143 and clone 10/100 Ethernet driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device miibus
device dc
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
if_dc_load="YES"
The dc
driver provides support for several
PCI Fast Ethernet adapters and embedded controllers based on the DEC/Intel
21143 chipset and clones.
All of supported chipsets have the same general register layout, DMA descriptor format and method of operation. All of the clone chips are based on the 21143 design with various modifications. The 21143 itself has support for 10baseT, BNC, AUI, MII and symbol media attachments, 10 and 100Mbps speeds in full or half duplex, built in NWAY autonegotiation and wake on LAN. The 21143 also offers several receive filter programming options including perfect filtering, inverse perfect filtering and hash table filtering.
Some clone chips duplicate the 21143 fairly closely while others
only maintain superficial similarities. Some support only MII media
attachments. Others use different receiver filter programming mechanisms. At
least one supports only chained DMA descriptors (most support both chained
descriptors and contiguously allocated fixed size rings). Some chips
(especially the PNIC) also have peculiar bugs. The
dc
driver does its best to provide generalized
support for all of these chipsets in order to keep special case code to a
minimum.
These chips are used by many vendors which makes it difficult to provide a complete list of all supported cards.
The dc
driver supports the following media
types:
autoselect
Note: the built-in NWAY autonegotiation on the original PNIC
82c168 chip is horribly broken and is not supported by the
dc
driver at this time (see the
BUGS section for details). The original
82c168 appears on very early revisions of the LinkSys LNE100TX and
Matrox FastNIC.
10baseT/UTP
mediaopt
option can also
be used to enable full-duplex
operation. Not
specifying full-duplex
implies
half-duplex
mode.100baseTX
mediaopt
option can also be used to enable
full-duplex
operation. Not specifying
full-duplex
implies
half-duplex
mode.The dc
driver supports the following media
options:
full-duplex
Note that the 100baseTX media type may not be available on certain Intel 21143 adapters which support 10Mbps media attachments only. For more information on configuring this device, see ifconfig(8).
The dc
driver provides support for the
following chipsets:
The following NICs are known to work with the
dc
driver at this time:
On sparc64 the dc
driver respects the
local-mac-address? system configuration variable for
the built in Sun DMFE 10/100 Mbps Ethernet interfaces on Sun Netra X1 and
Sun Fire V100. This system configuration variable can be set in the Open
Firmware boot monitor using the setenv
command or by
eeprom(8). If set to
“false
” (the default), the
dc
driver will use the system's default MAC address
for both of the built in devices. If set to
“true
”, the unique MAC address of each
interface is used rather than the system's default MAC address.
Note that this condition only occurs when warm booting from another operating system. If you power down your system prior to booting FreeBSD, the card should be configured correctly.
altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), vlan(4), eeprom(8), ifconfig(8)
ADMtek AL981, AL983 and AL985 data sheets, http://www.admtek.com.tw.
ASIX Electronics AX88140A and AX88141 data sheets, http://www.asix.com.tw.
Davicom DM9102 data sheet, http://www.davicom.com.tw/userfile/24247/DM9102H-DS-F01-021508.pdf.
Intel 21143 Hardware Reference Manual, http://developer.intel.com.
Macronix 98713/A, 98715/A and 98725 data sheets, http://www.macronix.com.
Macronix 98713/A and 98715/A app notes, http://www.macronix.com.
The dc
device driver first appeared in
FreeBSD 4.0.
The dc
driver was written by
Bill Paul
<wpaul@ee.columbia.edu>.
The Macronix application notes claim that in order to put the chips in normal operation, the driver must write a certain magic number into the CSR16 register. The numbers are documented in the app notes, but the exact meaning of the bits is not.
The 98713A seems to have a problem with 10Mbps full duplex mode. The transmitter works but the receiver tends to produce many unexplained errors leading to very poor overall performance. The 98715A does not exhibit this problem. All other modes on the 98713A seem to work correctly.
The original 82c168 PNIC chip has built in NWAY support which is used on certain early LinkSys LNE100TX and Matrox FastNIC cards, however it is horribly broken and difficult to use reliably. Consequently, autonegotiation is not currently supported for this chipset: the driver defaults the NIC to 10baseT half duplex, and it is up to the operator to manually select a different mode if necessary. (Later cards use an external MII transceiver to implement NWAY autonegotiation and work correctly.)
The dc
driver programs 82c168 and 82c169
PNIC chips to use the store and forward setting for the transmit start
threshold by default. This is to work around problems with some NIC/PCI bus
combinations where the PNIC can transmit corrupt frames when operating at
100Mbps, probably due to PCI DMA burst transfer errors.
The 82c168 and 82c169 PNIC chips also have a receiver bug that
sometimes manifests during periods of heavy receive and transmit activity,
where the chip will improperly DMA received frames to the host. The chips
appear to upload several kilobytes of garbage data along with the received
frame data, dirtying several RX buffers instead of just the expected one.
The dc
driver detects this condition and will
salvage the frame; however, it incurs a serious performance penalty in the
process.
The PNIC chips also sometimes generate a transmit underrun error
when the driver attempts to download the receiver filter setup frame, which
can result in the receive filter being incorrectly programmed. The
dc
driver will watch for this condition and requeue
the setup frame until it is transferred successfully.
The ADMtek AL981 chip (and possibly the AN985 as well) has been
observed to sometimes wedge on transmit: this appears to happen when the
driver queues a sequence of frames which cause it to wrap from the end of
the transmit descriptor ring back to the beginning. The
dc
driver attempts to avoid this condition by not
queuing any frames past the end of the transmit ring during a single
invocation of the dc_start
() routine. This
workaround has a negligible impact on transmit performance.
October 24, 2011 | Debian |