RL(4) | Device Drivers Manual | RL(4) |
rl
— RealTek
8129/8139 Fast Ethernet device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device miibus
device rl
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
if_rl_load="YES"
The rl
driver provides support for PCI
Ethernet adapters and embedded controllers based on the RealTek 8129 and
8139 Fast Ethernet controller chips.
The RealTek 8129/8139 series controllers use bus master DMA but do not use a descriptor-based data transfer mechanism. The receiver uses a single fixed size ring buffer from which packets must be copied into mbufs. For transmission, there are only four outbound packet address registers which require all outgoing packets to be stored as contiguous buffers. Furthermore, outbound packet buffers must be longword aligned or else transmission will fail.
The 8129 differs from the 8139 in that the 8139 has an internal PHY which is controlled through special direct access registers whereas the 8129 uses an external PHY via an MII bus. The 8139 supports both 10 and 100Mbps speeds in either full or half duplex. The 8129 can support the same speeds and modes given an appropriate PHY chip.
Note: support for the 8139C+ chip is provided by the re(4) driver.
The rl
driver supports the following media
types:
The rl
driver supports the following media
options:
Note that the 100baseTX media type is only available if supported by the adapter. For more information on configuring this device, see ifconfig(8).
Adapters supported by the rl
driver
include:
Note that this condition only occurs when warm booting from another operating system. If you power down your system prior to booting FreeBSD, the card should be configured correctly.
altq(4), arp(4), miibus(4), netintro(4), ng_ether(4), polling(4), ifconfig(8)
The RealTek 8129, 8139 and 8139C+ datasheets, http://www.realtek.com.tw.
The rl
device driver first appeared in
FreeBSD 3.0.
The rl
driver was written by
Bill Paul
<wpaul@ctr.columbia.edu>.
Since outbound packets must be longword aligned, the transmit routine has to copy an unaligned packet into an mbuf cluster buffer before transmission. The driver abuses the fact that the cluster buffer pool is allocated at system startup time in a contiguous region starting at a page boundary. Since cluster buffers are 2048 bytes, they are longword aligned by definition. The driver probably should not be depending on this characteristic.
The RealTek data sheets are of especially poor quality, and there is a lot of information missing particularly concerning the receiver operation. One particularly important fact that the data sheets fail to mention relates to the way in which the chip fills in the receive buffer. When an interrupt is posted to signal that a frame has been received, it is possible that another frame might be in the process of being copied into the receive buffer while the driver is busy handling the first one. If the driver manages to finish processing the first frame before the chip is done DMAing the rest of the next frame, the driver may attempt to process the next frame in the buffer before the chip has had a chance to finish DMAing all of it.
The driver can check for an incomplete frame by inspecting the frame length in the header preceding the actual packet data: an incomplete frame will have the magic length of 0xFFF0. When the driver encounters this value, it knows that it has finished processing all currently available packets. Neither this magic value nor its significance are documented anywhere in the RealTek data sheets.
January 16, 2013 | Debian |