INET(4) | Device Drivers Manual | INET(4) |
inet
— Internet
protocol family
#include
<sys/types.h>
#include <netinet/in.h>
The Internet protocol family is a collection of protocols layered
atop the
Internet
Protocol (IP) transport layer, and utilizing the Internet address
format. The Internet family provides protocol support for the
SOCK_STREAM
, SOCK_DGRAM
, and
SOCK_RAW
socket types; the
SOCK_RAW
interface provides access to the IP
protocol.
Internet addresses are four byte quantities, stored in network
standard format (on little endian machines, such as the alpha, amd64 and
i386 these are word and byte reversed). The include file
<netinet/in.h>
defines this
address as a discriminated union.
Sockets bound to the Internet protocol family utilize the following addressing structure,
struct sockaddr_in { uint8_t sin_len; sa_family_t sin_family; in_port_t sin_port; struct in_addr sin_addr; char sin_zero[8]; };
Sockets may be created with the local address
INADDR_ANY
to affect “wildcard”
matching on incoming messages. The address in a connect(2)
or sendto(2) call may be given as
INADDR_ANY
to mean “this host”. The
distinguished address INADDR_BROADCAST
is allowed as
a shorthand for the broadcast address on the primary network if the first
network configured supports broadcast.
The Internet protocol family is comprised of the IP network
protocol, Internet Control Message Protocol (ICMP), Internet Group
Management Protocol (IGMP), Transmission Control Protocol (TCP), and User
Datagram Protocol (UDP). TCP is used to support the
SOCK_STREAM
abstraction while UDP is used to support
the SOCK_DGRAM
abstraction. A raw interface to IP is
available by creating an Internet socket of type
SOCK_RAW
. The ICMP message protocol is accessible
from a raw socket.
The inet
address on an interface consist
of the address itself, the netmask, either broadcast address in case of a
broadcast interface or peers address in case of point-to-point interface.
The following ioctl(2) commands are provided for a
datagram socket in the Internet domain:
SIOCAIFADDR
SIOCDIFADDR
SIOCGIFADDR
SIOCGIFBRDADDR
SIOCGIFDSTADDR
SIOCGIFNETMASK
A number of variables are implemented in the net.inet branch of the sysctl(3) MIB. In addition to the variables supported by the transport protocols (for which the respective manual pages may be consulted), the following general variables are defined:
IPCTL_FORWARDING
IPCTL_SENDREDIRECTS
IPCTL_DEFTTL
IPCTL_ACCEPTSOURCEROUTE
IPCTL_SOURCEROUTE
ioctl(2), socket(2), getifaddrs(3), sysctl(3), icmp(4), intro(4), ip(4), ipfirewall(4), route(4), tcp(4), udp(4), pfil(9)
An Introductory 4.3 BSD Interprocess Communication Tutorial, PS1, 7.
An Advanced 4.3 BSD Interprocess Communication Tutorial, PS1, 8.
The inet
protocol interface appeared in
4.2BSD. The “protocol cloning” code
appeared in FreeBSD 2.1.
The Internet protocol support is subject to change as the Internet protocols develop. Users should not depend on details of the current implementation, but rather the services exported.
August 14, 2018 | Debian |