JOY(4) | Device Drivers Manual | JOY(4) |
joy
— joystick
device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device joy
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
joy_load="YES"
In /boot/device.hints:
hint.joy.0.at="isa"
hint.joy.0.port="0x201"
hint.joy.1.at="isa"
hint.joy.1.port="0x201"
#include <sys/joystick.h>
The joystick device driver allows applications to read the status of the PC joystick.
This device may be opened by only one process at a time.
The joystick status is read from a structure via a read() call. The structure is defined in the header file as follows:
struct joystick { int x; /* x position */ int y; /* y position */ int b1; /* button 1 status */ int b2; /* button 2 status */ };
Positions are typically in the range 0-2000.
Several ioctl() calls are also available. They take an argument of type int *
JOY_SETTIMEOUT
int *limitJOY_GETTIMEOUT
int *limitJOY_SET_X_OFFSET
int *offsetJOY_SET_Y_OFFSET
int *offsetJOY_GET_X_OFFSET
int *offsetJOY_GET_Y_OFFSET
int *offsetThe pinout of the DB-15 connector is as follow:
1 XY1 (+5v) 2 Switch 1 3 X1 (potentiometer #1) 4 Switch 1 (GND) 5 Switch 2 (GND) 6 Y1 (potentiometer #2) 7 Switch 2 8 N.C. 9 XY2 (+5v) 10 Switch 4 11 X2 (potentiometer #3) 12 Switch 3&4 (GND) 13 Y2 (potentiometer #4) 14 Switch 3 15 N.C.
Pots are normally 0-150k variable resistors (0-100k sometimes), and according to the IBM technical reference, the time is given by Time = 24.2e-6s + 0.011e-6s * R/Ohms
The joy
driver appeared in
FreeBSD 2.0.5.
Jean-Marc Zucconi <jmz@cabri.obs-besancon.fr>
January 23, 1995 | Debian |