DOKK / manpages / debian 10 / freebsd-manpages / memcchr.9freebsd.en
MEMCCHR(9) Kernel Developer's Manual MEMCCHR(9)

memcchrlocate the complement of a byte in byte string

#include <sys/libkern.h>

void *
memcchr(const void *b, int c, size_t len);

The () function locates the first occurrence of a byte unequal to c (converted to an unsigned char) in string b.

The memcchr() function returns a pointer to the byte located, or NULL if no such byte exists within len bytes.

memchr(3)

The memcchr() function first appeared in FreeBSD 10.0.

January 1, 2012 Debian