MLD(4) | Device Drivers Manual | MLD(4) |
mld
— Multicast
Listener Discovery Protocol
#include
<sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/in_systm.h>
#include <netinet/ip6.h>
#include <netinet/icmp6.h>
#include <netinet6/mld6.h>
int
socket
(AF_INET6,
SOCK_RAW,
IPPROTO_ICMPV6);
MLD is a control plane protocol used by IPv6 hosts and routers to
propagate multicast group membership information. Normally this protocol is
not used directly, except by the kernel itself, in response to multicast
membership requests by user applications. Multicast routing protocol daemons
may open a raw socket to directly interact with mld
and receive membership reports.
As of FreeBSD 8.0, MLD version 2 is implemented. This adds support for Source-Specific Multicast (SSM), whereby applications may communicate to upstream multicast routers that they are only interested in receiving multicast streams from particular sources. The retransmission of state-change reports adds some robustness to the protocol.
netstat(1), sourcefilter(3), icmp6(4), inet(4), multicast(4), ifmcstat(8)
The mld
manual page appeared in
FreeBSD 8.0.
April 8, 2013 | Debian |