NG_BLUETOOTH(4) | Device Drivers Manual | NG_BLUETOOTH(4) |
ng_bluetooth
—
placeholder for global Bluetooth variables
#include
<sys/types.h>
#include
<netgraph/bluetooth/include/ng_bluetooth.h>
The ng_bluetooth
module is a placeholder
for global Bluetooth variables. All Bluetooth variables can be examined and
changed via sysctl(8).
Below is the description of default variables. Each Bluetooth module might add its own variables to the tree.
Command_Complete
or
Command_Status
event from a Bluetooth device.Connection_Complete
event. Normally this should
not be required as Bluetooth devices have connection timeout of their own
and will send event back. This timeout is required to ensure that no
connection will stall in case when the HCI transport layer is broken. Be
careful when changing this variable. Make sure you understand what you are
doing.Inquiry
operation, the results will be put in
cache. Later when a Bluetooth device establishes a baseband connection, it
will try to find the matching entry in the cache and use it. This might
speed up establishment of the baseband connection.PENDING
status to the L2CAP control
command. In this case the L2CAP command timeout is reset to the ERTX
timeout value. The value of the ERTX timeout should be greater or equal to
the value of the RTX timeout. Be careful when changing this variable. Make
sure you understand what you are doing.The ng_bluetooth
module was implemented in
FreeBSD 5.0.
Maksim Yevmenkin <m_evmenkin@yahoo.com>
November 9, 2002 | Debian |