NG_TEE(4) | Device Drivers Manual | NG_TEE(4) |
ng_tee
— netgraph
``tee'' node type
#include
<sys/types.h>
#include
<netgraph/ng_tee.h>
The tee
node type has a purpose similar to
the tee(1) command. Tee
nodes are
useful for debugging or “snooping” on a connection between two
netgraph nodes. Tee
nodes have four hooks,
right
, left
,
right2left
, and left2right
.
All data received on right
is sent unmodified to
both hooks
left
and right2left
.
Similarly, all data received on left
is sent
unmodified to both right
and
left2right
.
Packets may also be received on right2left
and left2right
; if so, they are forwarded unchanged
out hooks right
and left
,
respectively.
This node type supports the following hooks:
This node type supports the generic control messages, plus the following.
NGM_TEE_GET_STATS
(getstats
)struct
ng_tee_stats
.NGM_TEE_CLR_STATS
(clrstats
)This node shuts down upon receipt of an
NGM_SHUTDOWN
control message, or when all hooks have
been disconnected. If both right
and
left
hooks are present, node removes itself from the
chain gently, connecting right
and
left
together.
The ng_tee
node type was implemented in
FreeBSD 4.0.
Julian Elischer <julian@FreeBSD.org>
May 28, 2004 | Debian |