NG_TTY(4) | Device Drivers Manual | NG_TTY(4) |
ng_tty
— netgraph
node type that is also a TTY hook
#include
<sys/types.h>
#include <sys/ttycom.h>
#include
<netgraph/ng_tty.h>
The tty
node type is both a netgraph node
type and a TTY hook.
The node has a single hook called hook
.
Incoming bytes received on the tty device are sent out on this hook, and
frames received on hook
are transmitted out on the
tty device. No modification to the data is performed in either direction.
While the hook is installed on a tty, the normal read and write operations
are unavailable, returning EIO
.
Incoming data is delivered directly to ng_tty via the tty bypass hook as a buffer pointer and length, this is converted to a mbuf and passed to the peer.
The node supports an optional “hot character”. If
the driver can not deliver data directly to the tty bypass hook then each
character is input one at a time. If set to non-zero and bypass mode is
unavailable, incoming data from the tty device is queued until this
character is seen. This avoids sending lots of mbufs containing a small
number of bytes, but introduces potentially infinite latency. The default
hot character is 0x7e, consistent with hook
being
connected to a ng_async(4) type node. The hot character
has no effect on the transmission of data.
This node type supports the following hooks:
mbuf
structures, with arbitrary inter-frame
boundaries.This node type supports the generic control messages, plus the following:
NGM_TTY_SET_HOTCHAR
NGM_TTY_GET_HOTCHAR
NGM_TTY_SET_TTY
This node shuts down when the corresponding device is closed.
The ng_tty
node type was implemented in
FreeBSD 4.0.
Archie Cobbs
<archie@FreeBSD.org>
Andrew Thompson
<thompsa@FreeBSD.org>
The serial driver code also has a notion of a “hot
character”. Unfortunately, this value is statically defined in terms
of the line discipline and cannot be changed. Therefore, if a hot character
other than 0x7e (the default) is set for the ng_tty
node, the node has no way to convey this information to the serial driver,
and sub-optimal performance may result.
December 25, 2008 | Debian |