NG_VLAN(4) | Device Drivers Manual | NG_VLAN(4) |
ng_vlan
— IEEE
802.1Q VLAN tagging netgraph node type
#include
<sys/types.h>
#include <netgraph.h>
#include
<netgraph/ng_vlan.h>
The vlan
node type multiplexes frames
tagged according to the IEEE 802.1Q standard between different hooks.
Each node has two special hooks, downstream and nomatch, and an arbitrary number of “vlan” hooks, each associated with a particular VLAN tag.
An ETHERTYPE_VLAN
frame received on the
downstream hook with a tag that the node has been
configured to filter is sent out the corresponding “vlan”
hook. If it does not match any of the configured tags, or is not of a type
ETHERTYPE_VLAN
, it is sent out the
nomatch hook. If the nomatch
hook is not connected, the packet is dropped.
An Ethernet frame received on the nomatch hook is passed unmodified to the downstream hook.
An Ethernet frame received on any of the “vlan” hooks is tagged accordingly and sent out the downstream hook.
This node type supports the following hooks:
This node type supports the generic control messages, plus the following:
NGM_VLAN_ADD_FILTER
(addfilter
)NGM_VLAN_DEL_FILTER
(delfilter
)NGM_VLAN_GET_TABLE
(gettable
)#!/bin/sh ETHER_IF=rl0 ngctl -f- <<EOF shutdown ${ETHER_IF}: mkpeer ${ETHER_IF}: vlan lower downstream name ${ETHER_IF}:lower vlan connect ${ETHER_IF}: vlan: upper nomatch EOF ngctl mkpeer vlan: eiface vlan123 ether ngctl msg vlan: addfilter '{ vlan=123 hook="vlan123" }'
This node shuts down upon receipt of a
NGM_SHUTDOWN
control message, or when all hooks have
been disconnected.
The ng_vlan
node type appeared in
FreeBSD 4.10.
Ruslan Ermilov <ru@FreeBSD.org>
March 1, 2004 | Debian |