RMLOCK(9) | Kernel Developer's Manual | RMLOCK(9) |
rmlock
, rm_init
,
rm_init_flags
, rm_destroy
,
rm_rlock
, rm_try_rlock
,
rm_wlock
, rm_runlock
,
rm_wunlock
, rm_wowned
,
rm_sleep
, rm_assert
,
RM_SYSINIT
, RM_SYSINIT_FLAGS
— kernel reader/writer lock optimized for
read-mostly access patterns
#include
<sys/param.h>
#include <sys/lock.h>
#include <sys/rmlock.h>
void
rm_init
(struct
rmlock *rm, const char
*name);
void
rm_init_flags
(struct
rmlock *rm, const char
*name, int
opts);
void
rm_destroy
(struct
rmlock *rm);
void
rm_rlock
(struct
rmlock *rm, struct
rm_priotracker* tracker);
int
rm_try_rlock
(struct
rmlock *rm, struct
rm_priotracker* tracker);
void
rm_wlock
(struct
rmlock *rm);
void
rm_runlock
(struct
rmlock *rm, struct
rm_priotracker* tracker);
void
rm_wunlock
(struct
rmlock *rm);
int
rm_wowned
(const
struct rmlock *rm);
int
rm_sleep
(void
*wchan, struct rmlock
*rm, int priority,
const char *wmesg,
int timo);
options INVARIANTS
options INVARIANT_SUPPORT
void
rm_assert
(struct
rmlock *rm, int
what);
#include
<sys/kernel.h>
RM_SYSINIT
(name,
struct rmlock *rm,
const char *desc);
RM_SYSINIT_FLAGS
(name,
struct rmlock *rm,
const char *desc,
int flags);
Read-mostly locks allow shared access to protected data by multiple threads, or exclusive access by a single thread. The threads with shared access are known as readers since they only read the protected data. A thread with exclusive access is known as a writer since it can modify protected data.
Read-mostly locks are designed to be efficient for locks almost exclusively used as reader locks and as such should be used for protecting data that rarely changes. Acquiring an exclusive lock after the lock has been locked for shared access is an expensive operation.
Normal read-mostly locks are similar to
rwlock(9) locks and follow the same lock ordering rules as
rwlock(9) locks. Read-mostly locks have full priority
propagation like mutexes. Unlike rwlock(9), read-mostly
locks propagate priority to both readers and writers. This is implemented
via the rm_priotracker structure argument supplied to
rm_rlock
()
and
rm_runlock
().
Readers can recurse if the lock is initialized with the
RM_RECURSE
option; however, writers are never
allowed to recurse.
Sleepable read-mostly locks are created by
passing RM_SLEEPABLE
to
rm_init_flags
().
Unlike normal read-mostly locks, sleepable read-mostly locks follow the same
lock ordering rules as sx(9) locks. Sleepable read-mostly
locks do not propagate priority to writers, but they do propagate priority
to readers. Writers are permitted to sleep while holding a read-mostly lock,
but readers are not. Unlike other sleepable locks such as
sx(9) locks, readers must use try operations on other
sleepable locks to avoid sleeping.
rm_init
(struct
rmlock *rm, const char *name)rm_init_flags
(struct rmlock
*rm, const char *name, int
opts)rm_init
(), initialize the read-mostly
lock rm with a set of optional flags. The
opts arguments contains one or more of the following
flags:
RM_NOWITNESS
RM_RECURSE
RM_SLEEPABLE
RM_NEW
option
INVARIANTS
, rm_init_flags
() will assert
that the rm has not been initialized multiple
times without intervening calls to
rm_destroy
()
unless this option is specified.rm_rlock
(struct rmlock *rm,
struct rm_priotracker* tracker)rmlock
and must persist until
rm_runlock
() has been called. This data structure
can be allocated on the stack since readers cannot sleep. If any thread
holds this lock exclusively, the current thread blocks, and its priority
is propagated to the exclusive holder. If the lock was initialized with
the RM_RECURSE
option the
rm_rlock
() function can be called when the current
thread has already acquired reader access on
rm.rm_try_rlock
(struct
rmlock *rm, struct rm_priotracker* tracker)rm_try_rlock
() will return 0 if the lock cannot be
acquired immediately; otherwise, the lock will be acquired and a non-zero
value will be returned. Note that rm_try_rlock
()
may fail even while the lock is not currently held by a writer. If the
lock was initialized with the RM_RECURSE
option,
rm_try_rlock
() will succeed if the current thread
has already acquired reader access.rm_wlock
(struct
rmlock *rm)rm_wlock
() function cannot be called
recursively.rm_runlock
(struct rmlock
*rm, struct rm_priotracker* tracker)rm_rlock
(). The tracker
argument must match the tracker argument used for
acquiring the shared lockrm_wunlock
(struct
rmlock *rm)rm_wlock
().rm_destroy
(struct rmlock
*rm)rm_init
(). The rm lock must
be unlocked.rm_wowned
(const
struct rmlock *rm)rm_sleep
(void
*wchan, struct rmlock *rm, int
priority, const char *wmesg, int
timo)rm_assert
(struct
rmlock *rm, int what)options
INVARIANTS
and options INVARIANT_SUPPORT
,
the kernel will panic. Currently the following base assertions are
supported:
RA_LOCKED
RA_RLOCKED
RA_WLOCKED
RA_UNLOCKED
In addition, one of the following optional flags may be
specified with RA_LOCKED
,
RA_RLOCKED
, or
RA_WLOCKED
:
RA_RECURSED
RA_NOTRECURSED
locking(9), mutex(9), panic(9), rwlock(9), sema(9), sleep(9), sx(9)
These functions appeared in FreeBSD 7.0.
The rmlock
facility was written by
Stephan Uphoff. This manual page was written by
Gleb Smirnoff for rwlock and modified to reflect
rmlock by Stephan Uphoff.
The rmlock
implementation is currently not
optimized for single processor systems.
rm_try_rlock
() can fail transiently even
when there is no writer, while another reader updates the state on the local
CPU.
The rmlock
implementation uses a single
per CPU list shared by all rmlocks in the system. If rmlocks become popular,
hashing to multiple per CPU queues may be needed to speed up the writer lock
process.
November 11, 2017 | Debian |