RTWN(4) | Device Drivers Manual | RTWN(4) |
rtwn
— Realtek
IEEE 802.11 wireless network driver
options RTWN_DEBUG
options RTWN_WITHOUT_UCODE
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device rtwn
device rtwnfw
device rtwn_usb
device rtwn_pci
device wlan
device firmware
Alternatively, to load the driver as a module at boot time, place following lines in loader.conf(5):
if_rtwn_pci_load="YES" if_rtwn_usb_load="YES"
The rtwn
driver provides support for
wireless network devices based on the Realtek RTL8192C, RTL8188E, RTL8192E,
RTL8812A and RTL8821A programming APIs. These APIs are used by a wide
variety of chips; most chips with USB and some with PCI interface are
supported.
To enable use for PCI/PCIe systems, see the rtwn_pci(4) driver; for USB devices, use the rtwn_usb(4) driver.
The driver supports station
,
adhoc
, hostap
and
monitor
mode operation. There are no limitations for
number of monitor
mode virtual interfaces; in
addition to any other virtual interface one station
interface can be added (Note: RTL8821AU supports two non-monitor mode
interfaces at the same time).
All chips have hardware support for WEP, AES-CCM and TKIP encryption.
The rtwn
driver can be configured at
runtime with ifconfig(8).
rtwn
firmware licenseThe driver (if not compiled with options
RTWN_WITHOUT_UCODE
) may use following firmware files, which are
loaded when an interface is brought up:
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev rtwn0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with network name
“my_net
”:
ifconfig wlan create wlandev rtwn0
ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev rtwn0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
Create an IBSS network with 128-bit WEP encryption on the channel 4:
ifconfig wlan create wlandev rtwn0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1 \ channel 4
Join/create an 802.11b IBSS network with network name
“my_net
”:
ifconfig wlan0 create wlandev rtwn0 wlanmode adhoc ifconfig wlan0 inet 192.168.0.22 netmask 0xffffff00 ssid my_net \ mode 11b
Create a host-based access point:
ifconfig wlan0 create wlandev rtwn0 wlanmode hostap ifconfig wlan0 inet 192.168.0.10 netmask 0xffffff00 ssid my_ap
Tunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
intro(4), netintro(4), rtwn_pci(4), rtwn_usb(4), rtwnfw(4), wlan(4), wlan_amrr(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), wlan_xauth(4), hostapd(8), ifconfig(8), wpa_supplicant(8)
The urtwn
driver first appeared in
OpenBSD 4.9 and FreeBSD
10.0; the rtwn
driver first appeared in
OpenBSD 5.8.
The rtwn
driver was initially written by
Stefan Sperling
<stsp@openbsd.org>
and ported by Kevin Lo
<kevlo@freebsd.org>.
It was based on the urtwn
driver written by
Damien Bergamini
<damien.bergamini@free.fr>.
The rtwn
driver currently does not
implement firmware-based rate control.
July 31, 2017 | Debian |