SEM(4) | Device Drivers Manual | SEM(4) |
sem
— POSIX
semaphores
To compile this driver into the kernel, place the following line in your kernel configuration file:
options
P1003_1B_SEMAPHORES
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
sem_load="YES"
To load the driver as a module at run-time, run the following command as root:
The sem
facility provides system calls
used by the standard C library (libc) to implement
POSIX semaphores. This facility offers support for such functions as
sem_init
()
and
sem_wait
().
It is available both as a kernel option for static inclusion and as a
dynamic kernel module.
sem_destroy(3), sem_getvalue(3), sem_init(3), sem_open(3), sem_post(3), sem_wait(3), config(8), kldload(8), kldunload(8)
The sem
facility appeared in
FreeBSD 5.0.
February 7, 2014 | Debian |