UHID(4) | Device Drivers Manual | UHID(4) |
uhid
— USB generic
HID support
To compile this driver into the kernel, place the following line in your kernel configuration file:
device uhid
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
uhid_load="YES"
The uhid
driver provides support for all
HID (Human Interface Device) interfaces in USB devices that do not have a
special driver.
The device handles the following ioctl(2) calls:
USB_GET_REPORT_ID
(int)USB_GET_REPORT_DESC
(struct usb_gen_descriptor)struct usb_gen_descriptor { void *ugd_data; uint16_t ugd_maxlen; uint16_t ugd_actlen; uint8_t ugd_report_type; ... };
USB_SET_IMMED
(int)USB_GET_REPORT
(struct usb_gen_descriptor)UHID_INPUT_REPORT
,
UHID_OUTPUT_REPORT
, or
UHID_FEATURE_REPORT
. This call may fail if the
device does not support this feature.USB_SET_REPORT
(struct usb_gen_descriptor)UHID_INPUT_REPORT
,
UHID_OUTPUT_REPORT
, or
UHID_FEATURE_REPORT
. The value of the report is
specified by the ugd_data and the
ugd_maxlen fields. This call may fail if the device
does not support this feature.Use read(2) to get data from the device. Data should be read in chunks of the size prescribed by the report descriptor.
Use write(2) to send data to the device. Data should be written in chunks of the size prescribed by the report descriptor.
The following variables are available as both sysctl(8) variables and loader(8) tunables:
The uhid
driver appeared in
NetBSD 1.4. This manual page was adopted from
NetBSD by Tom Rhodes
<trhodes@FreeBSD.org>
in April 2002.
July 1, 2018 | Debian |