DOKK / manpages / debian 10 / freebsd-manpages / vfs_suser.9freebsd.en
VFS_SUSER(9) Kernel Developer's Manual VFS_SUSER(9)

vfs_susercheck if credentials have superuser privileges for a mount point

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/mount.h>

int
vfs_suser(struct mount *mp, struct thread *td);

The () function checks if the credentials given include superuser powers for the given mount point. It will check to see if the thread passed in has the same credentials as the user that mounted the file system. If so, it returns 0, otherwise it returns what priv_check(9) would have returned.

The vfs_suser() function returns 0 if the user has superuser powers and EPERM otherwise. This is the of some other implementations of suser() in which a TRUE response indicates superuser powers.

chroot(2), jail(2)

The vfs_suser() function was introduced in FreeBSD 5.2.

This manual page was written by Alfred Perlstein.

April 2, 2004 Debian