XEN(4) | Device Drivers Manual | XEN(4) |
xen
— Xen
Hypervisor Guest (DomU) Support
To compile hardware-assisted virtualization (HVM) Xen guest support with para-virtualized drivers into an amd64 or i386 kernel, place the following lines in your kernel configuration file:
options XENHVM
device xenpci
The Xen Hypervisor allows multiple virtual machines to be run on a single computer system. When first released, Xen required that i386 kernels be compiled "para-virtualized" as the x86 instruction set was not fully virtualizable. Primarily, para-virtualization modifies the virtual memory system to use hypervisor calls (hypercalls) rather than direct hardware instructions to modify the TLB, although para-virtualized device drivers were also required to access resources such as virtual network interfaces and disk devices.
With later instruction set extensions from AMD and Intel to support fully virtualizable instructions, unmodified virtual memory systems can also be supported; this is referred to as hardware-assisted virtualization (HVM). HVM configurations may either rely on transparently emulated hardware peripherals, or para-virtualized drivers, which are aware of virtualization, and hence able to optimize certain behaviors to improve performance or semantics.
FreeBSD supports hardware-assisted virtualization (HVM) on both i386 and amd64 kernels.
Para-virtualized device drivers are required in order to support certain functionality, such as processing management requests, returning idle physical memory pages to the hypervisor, etc.
These para-virtualized drivers are supported:
balloon
blkback
blkfront
.blkfront
console
control
evtchn
netback
netfront
.netfront
pcifront
xenpci
In general, PV drivers will perform better than emulated hardware, and are the recommended configuration for HVM installations.
Using a hypervisor introduces a second layer of scheduling that may limit the effectiveness of certain FreeBSD scheduling optimisations. Among these is adaptive locking, which is no longer able to determine whether a thread holding a lock is in execution. It is recommended that adaptive locking be disabled when using Xen:
options NO_ADAPTIVE_MUTEXES
options NO_ADAPTIVE_RWLOCKS
options NO_ADAPTIVE_SX
Support for xen
first appeared in
FreeBSD 8.1.
FreeBSD support for Xen was first added by Kip Macy <kmacy@FreeBSD.org> and Doug Rabson <dfr@FreeBSD.org>. Further refinements were made by Justin Gibbs <gibbs@FreeBSD.org>, Adrian Chadd <adrian@FreeBSD.org>, and Colin Percival <cperciva@FreeBSD.org>. This manual page was written by Robert Watson <rwatson@FreeBSD.org>.
FreeBSD is only able to run as a Xen guest (DomU) and not as a Xen host (Dom0).
As of this release, Xen PV DomU support is not heavily tested; instability has been reported during VM migration of PV kernels.
Certain PV driver features, such as the balloon driver, are under-exercised.
April 30, 2015 | Debian |