ZPOOL(8) | System Manager's Manual (smm) | ZPOOL(8) |
zpool
— configure
ZFS storage pools
zpool |
- ? |
zpool |
add [-fgLnP ]
[-o
property=value]
pool vdev... |
zpool |
attach [-f ]
[-o
property=value]
pool device new_device |
zpool |
clear pool
[device] |
zpool |
create [-dfn ]
[-m mountpoint]
[-o
property=value]...
[-o
feature@feature=value]
[-O
file-system-property=value]...
[-R root]
pool vdev... |
zpool |
destroy [-f ]
pool |
zpool |
detach pool device |
zpool |
events [-vHfc ]
[pool] |
zpool |
export [-a ]
[-f ] pool... |
zpool |
get [-Hp ]
[-o
field[,field]...]
all|property[,property]...
pool... |
zpool |
history [-il ]
[pool]... |
zpool |
import [-D ]
[-c
cachefile|-d
dir] |
zpool |
import -a
[-DfmN ] [-F
[-n ] [-T ]
[-X ]] [-c
cachefile|-d
dir] [-o
mntopts] [-o
property=value]...
[-R root] |
zpool |
import [-Dfm ]
[-F [-n ]
[-T ] [-X ]]
[-c
cachefile|-d
dir] [-o
mntopts] [-o
property=value]...
[-R root]
[-s ]
pool|id
[newpool [-t ]] |
zpool |
iostat [[[-c
SCRIPT]
[-lq ]]|-rw ]
[-T u|d]
[-ghHLpPvy ]
[[pool...]|[pool
vdev...]|[vdev...]]
[interval [count]] |
zpool |
labelclear [-f ]
device |
zpool |
list [-HgLpPv ]
[-o
property[,property]...]
[-T u|d]
[pool]... [interval
[count]] |
zpool |
offline [-f ]
[-t ] pool
device... |
zpool |
online [-e ]
pool device... |
zpool |
reguid pool |
zpool |
reopen pool |
zpool |
remove pool
device... |
zpool |
replace [-f ]
[-o
property=value]
pool device
[new_device] |
zpool |
scrub [-s |
-p ] pool... |
zpool |
set
property=value
pool |
zpool |
split [-gLnP ]
[-o
property=value]...
[-R root]
pool newpool [device]... |
zpool |
status [-c
SCRIPT] [-gLPvxD ]
[-T u|d]
[pool]... [interval
[count]] |
zpool |
sync [pool]... |
zpool |
upgrade |
zpool |
upgrade -v |
zpool |
upgrade [-V
version]
-a |pool... |
The zpool
command configures ZFS storage
pools. A storage pool is a collection of devices that provides physical
storage and data replication for ZFS datasets. All datasets within a storage
pool share the same space. See zfs(8) for information on
managing datasets.
A "virtual device" describes a single device or a collection of devices organized according to certain performance and fault characteristics. The following virtual devices are supported:
A raidz group can have single-, double-, or triple-parity, meaning that the raidz group can sustain one, two, or three failures, respectively, without losing any data. The raidz1 vdev type specifies a single-parity raidz group; the raidz2 vdev type specifies a double-parity raidz group; and the raidz3 vdev type specifies a triple-parity raidz group. The raidz vdev type is an alias for raidz1.
A raidz group with N disks of size X with P parity disks can hold approximately (N-P)*X bytes and can withstand P device(s) failing before data integrity is compromised. The minimum number of devices in a raidz group is one more than the number of parity disks. The recommended number is between 3 and 9 to help increase performance.
Virtual devices cannot be nested, so a mirror or raidz virtual device can only contain files or disks. Mirrors of mirrors (or other combinations) are not allowed.
A pool can have any number of virtual devices at the top of the configuration (known as "root vdevs"). Data is dynamically distributed across all top-level devices to balance data among devices. As new virtual devices are added, ZFS automatically places data on the newly available devices.
Virtual devices are specified one at a time on the command line, separated by whitespace. The keywords mirror and raidz are used to distinguish where a group ends and another begins. For example, the following creates two root vdevs, each a mirror of two disks:
# zpool create mypool mirror sda sdb mirror sdc sdd
ZFS supports a rich set of mechanisms for handling device failure and data corruption. All metadata and data is checksummed, and ZFS automatically repairs bad data from a good copy when corruption is detected.
In order to take advantage of these features, a pool must make use of some form of redundancy, using either mirrored or raidz groups. While ZFS supports running in a non-redundant configuration, where each root vdev is simply a disk or file, this is strongly discouraged. A single case of bit corruption can render some or all of your data unavailable.
A pool's health status is described by one of three states: online, degraded, or faulted. An online pool has all devices operating normally. A degraded pool is one in which one or more devices have failed, but the data is still available due to a redundant configuration. A faulted pool has corrupted metadata, or one or more faulted devices, and insufficient replicas to continue functioning.
The health of the top-level vdev, such as mirror or raidz device, is potentially impacted by the state of its associated vdevs, or component devices. A top-level vdev or component device is in one of the following states:
One or more component devices is in the degraded or faulted state, but sufficient replicas exist to continue functioning. The underlying conditions are as follows:
One or more component devices is in the faulted state, and insufficient replicas exist to continue functioning. The underlying conditions are as follows:
zpool
offline
command.If a device is removed and later re-attached to the system, ZFS attempts to put the device online automatically. Device attach detection is hardware-dependent and might not be supported on all platforms.
ZFS allows devices to be associated with pools as "hot spares". These devices are not actively used in the pool, but when an active device fails, it is automatically replaced by a hot spare. To create a pool with hot spares, specify a spare vdev with any number of devices. For example,
# zpool create pool mirror sda sdb spare sdc sdd
Spares can be shared across multiple pools, and can be added with
the zpool
add
command and
removed with the zpool
remove
command. Once a spare replacement is
initiated, a new spare vdev is created within the
configuration that will remain there until the original device is replaced.
At this point, the hot spare becomes available again if another device
fails.
If a pool has a shared spare that is currently being used, the pool can not be exported since other pools may use this shared spare, which may lead to potential data corruption.
An in-progress spare replacement can be canceled by detaching the hot spare. If the original faulted device is detached, then the hot spare assumes its place in the configuration, and is removed from the spare list of all active pools.
Spares cannot replace log devices.
The ZFS Intent Log (ZIL) satisfies POSIX requirements for synchronous transactions. For instance, databases often require their transactions to be on stable storage devices when returning from a system call. NFS and other applications can also use fsync(2) to ensure data stability. By default, the intent log is allocated from blocks within the main pool. However, it might be possible to get better performance using separate intent log devices such as NVRAM or a dedicated disk. For example:
# zpool create pool sda sdb log sdc
Multiple log devices can also be specified, and they can be mirrored. See the EXAMPLES section for an example of mirroring multiple log devices.
Log devices can be added, replaced, attached, detached, and imported and exported as part of the larger pool. Mirrored log devices can be removed by specifying the top-level mirror for the log.
Devices can be added to a storage pool as "cache devices". These devices provide an additional layer of caching between main memory and disk. For read-heavy workloads, where the working set size is much larger than what can be cached in main memory, using cache devices allow much more of this working set to be served from low latency media. Using cache devices provides the greatest performance improvement for random read-workloads of mostly static content.
To create a pool with cache devices, specify a cache vdev with any number of devices. For example:
# zpool create pool sda sdb cache sdc sdd
Cache devices cannot be mirrored or part of a raidz configuration. If a read error is encountered on a cache device, that read I/O is reissued to the original storage pool device, which might be part of a mirrored or raidz configuration.
The content of the cache devices is considered volatile, as is the case with other system caches.
Each pool has several properties associated with it. Some properties are read-only statistics while others are configurable and change the behavior of the pool.
The following are read-only properties:
zpool
online
-e
). This space occurs when a LUN is dynamically
expanded.The space usage properties report actual physical space available
to the storage pool. The physical space can be different from the total
amount of space that any contained datasets can actually use. The amount of
space used in a raidz configuration depends on the characteristics of the
data being written. In addition, ZFS reserves some space for internal
accounting that the zfs(8) command takes into account, but
the zpool
command does not. For non-full pools of a
reasonable size, these effects should be invisible. For small pools, or
pools that are close to being completely full, these discrepancies may
become more noticeable.
The following property can be set at creation time and import time:
The following property can be set only at import time:
The following properties can be set at creation time and import
time, and later changed with the zpool
set
command:
zpool
replace
command. If
set to on, any new device, found in the same physical
location as a device that previously belonged to the pool, is
automatically formatted and replaced. The default behavior is
off. This property can also be referred to by its
shortened column name,
replace.
Autoreplace can also be used with virtual disks (like device mapper)
provided that you use the /dev/disk/by-vdev paths setup by vdev_id.conf.
See the vdev_id(8) man page for more details.
Autoreplace and autoonline require the ZFS Event Daemon be configured and
running. See the zed(8) man page for more details.zpool
import
-c
. Setting it to the special value
none creates a temporary pool that is never cached, and
the special value "" (empty string) uses the default location.
Multiple pools can share the same cache file. Because the kernel destroys and recreates this file when pools are added and removed, care should be taken when attempting to access this file. When the last pool using a cachefile is exported or destroyed, the file will be empty.
EIO
to any new write I/O requests but
allows reads to any of the remaining healthy devices. Any write
requests that have yet to be committed to disk would be blocked.zfs
list
is
run without the -t
option. The default value is
off. This property can also be referred to by its
shortened name,
listsnaps.zpool
import
. When a pool
is determined to be active it cannot be imported, even with the
-f
option. This property is intended to be used in
failover configurations where multiple hosts have access to a pool on
shared storage. When this property is on, periodic writes to storage occur
to show the pool is in use. See
zfs_multihost_interval
in the zfs-module-parameters(5) man page. In order to
enable this property each host must set a unique hostid. See
genhostid(1) zgenhostid(8)
spl-module-parameters(5) for additional details. The
default value is off.zpool
upgrade
command,
though this property can be used when a specific version is needed for
backwards compatibility. Once feature flags are enabled on a pool this
property will no longer have a value.All subcommands that modify state are logged persistently to the pool in their original form.
The zpool
command provides subcommands to
create and destroy storage pools, add capacity to storage pools, and provide
information about the storage pools. The following subcommands are
supported:
zpool
-
?zpool
add
[-fgLnP
] [-o
property=value]
pool vdev...-f
option, and the device checks
performed are described in the zpool
create
subcommand.
-f
-g
-L
-n
-P
-o
property=valuezpool
attach
[-f
] [-o
property=value]
pool device new_device-f
-o
property=valuezpool
clear
pool [device]zpool
create
[-dfn
] [-m
mountpoint] [-o
property=value]...
[-o
feature@feature=value]...
[-O
file-system-property=value]...
[-R
root]
[-t
tname]
pool vdev...The command verifies that each device specified is accessible
and not currently in use by another subsystem. There are some uses, such
as being currently mounted, or specified as the dedicated dump device,
that prevents a device from ever being used by ZFS. Other uses, such as
having a preexisting UFS file system, can be overridden with the
-f
option.
The command also checks that the replication strategy for the
pool is consistent. An attempt to combine redundant and non-redundant
storage in a single pool, or to mix disks and files, results in an error
unless -f
is specified. The use of differently
sized devices within a single raidz or mirror group is also flagged as
an error unless -f
is specified.
Unless the -R
option is specified, the
default mount point is
/pool. The mount point
must not exist or must be empty, or else the root dataset cannot be
mounted. This can be overridden with the -m
option.
By default all supported features are enabled on the new pool
unless the -d
option is specified.
-d
-o
option.
See zpool-features(5) for details about feature
properties.-f
-m
mountpoint-n
-o
property=value-o
feature@feature=value-O
file-system-property=value-R
root-o
cachefile=none
-o
altroot=root-t
tnamezpool
destroy
[-f
] pool-f
zpool
detach
pool devicezpool
events
[-cfHv
] [pool...]zpool
export
[-a
] [-f
]
pool...Before exporting the pool, all datasets within the pool are unmounted. A pool can not be exported if it has a shared spare that is currently being used.
For pools to be portable, you must give the
zpool
command whole disks, not just partitions,
so that ZFS can label the disks with portable EFI labels. Otherwise,
disk drivers on platforms of different endianness will not recognize the
disks.
zpool
get
[-Hp
] [-o
field[,field]...]
all|property[,property]...
pool...name Name of storage pool property Property name value Property value source Property source, either 'default' or 'local'.
See the Properties section for more information on the available pool properties.
zpool
history
[-il
] [pool]...zpool
import
[-D
] [-c
cachefile|-d
dir]-d
option
is not specified, this command searches for devices in
/dev. The -d
option can be
specified multiple times, and all directories are searched. If the device
appears to be part of an exported pool, this command displays a summary of
the pool with the name of the pool, a numeric identifier, as well as the
vdev layout and current health of the device for each device or file.
Destroyed pools, pools that were previously destroyed with the
zpool
destroy
command, are
not listed unless the -D
option is specified.
The numeric identifier is unique, and can be used instead of the pool name when multiple exported pools of the same name are available.
zpool
import
-a
[-DfmN
]
[-F
[-n
]
[-T
] [-X
]]
[-c
cachefile|-d
dir] [-o
mntopts] [-o
property=value]...
[-R
root]
[-s
]zpool
destroy
command, will not be imported unless the
-D
option is specified.
-a
-c
cachefile-d
dir-d
option can be specified multiple times.
This option is incompatible with the -c
option.-D
-f
option is
also required.-f
-F
-m
-n
-F
recovery option. Determines
whether a non-importable pool can be made importable again, but does
not actually perform the pool recovery. For more details about pool
recovery mode, see the -F
option, above.-N
-o
mntopts-o
property=value-R
root-s
-X
-F
recovery option. Determines
whether extreme measures to find a valid txg should take place. This
allows the pool to be rolled back to a txg which is no longer
guaranteed to be consistent. Pools imported at an inconsistent txg may
contain uncorrectable checksum errors. For more details about pool
recovery mode, see the -F
option, above.
WARNING: This option can be extremely hazardous to the health of your
pool and should only be used as a last resort.-T
-FX
. For more details about pool recovery
mode, see the -X
option, above. WARNING: This
option can be extremely hazardous to the health of your pool and
should only be used as a last resort.zpool
import
[-Dfm
] [-F
[-n
] [-t
]
[-T
] [-X
]]
[-c
cachefile|-d
dir] [-o
mntopts] [-o
property=value]...
[-R
root]
[-s
]
pool|id
[newpool]If a device is removed from a system without running
zpool
export
first, the
device appears as potentially active. It cannot be determined if this
was a failed export, or whether the device is really in use from another
host. To import a pool in this state, the -f
option is required.
-c
cachefile-d
dir-d
option can be specified multiple times.
This option is incompatible with the -c
option.-D
-f
option is also
required.-f
-F
-m
-n
-F
recovery option. Determines
whether a non-importable pool can be made importable again, but does
not actually perform the pool recovery. For more details about pool
recovery mode, see the -F
option, above.-o
mntopts-o
property=value-R
root-s
-X
-F
recovery option. Determines
whether extreme measures to find a valid txg should take place. This
allows the pool to be rolled back to a txg which is no longer
guaranteed to be consistent. Pools imported at an inconsistent txg may
contain uncorrectable checksum errors. For more details about pool
recovery mode, see the -F
option, above.
WARNING: This option can be extremely hazardous to the health of your
pool and should only be used as a last resort.-T
-FX
. For more details about pool recovery
mode, see the -X
option, above. WARNING: This
option can be extremely hazardous to the health of your pool and
should only be used as a last resort.-t
zpool
iostat
[[[-c
SCRIPT]
[-lq
]]|-rw
]
[-T
u|d]
[-ghHLpPvy
]
[[pool...]|[pool
vdev...]|[vdev...]]
[interval [count]]-y
flag. Also note that the
units of K,
M,
G ... that are
printed in the report are in base 1024. To get the raw values, use the
-p
flag.
-c
[SCRIPT1[,SCRIPT2]...]zpool
iostat
output. Users can run any script found
in their ~/.zpool.d directory or from the
system /etc/zfs/zpool.d directory. Script
names containing the slash (/) character are not allowed. The default
search path can be overridden by setting the ZPOOL_SCRIPTS_PATH
environment variable. A privileged user can run
-c
if they have the ZPOOL_SCRIPTS_AS_ROOT
environment variable set. If a script requires the use of a privileged
command, like smartctl(8), then it's recommended you
allow the user access to it in /etc/sudoers or
add the user to the /etc/sudoers.d/zfs file.
If -c
is passed without a script
name, it prints a list of all scripts. -c
also sets verbose mode
(-v
).
Script output should be in the form of "name=value". The column name is set to "name" and the value is set to "value". Multiple lines can be used to output multiple columns. The first line of output not in the "name=value" format is displayed without a column title, and no more output after that is displayed. This can be useful for printing error messages. Blank or NULL values are printed as a '-' to make output awk-able.
The following environment variables are set before running each script:
-T
u|d-g
-H
-L
-p
-P
-L
flag.-r
-v
-y
-w
total_wait: Total IO time (queuing + disk IO time). disk_wait: Disk IO time (time reading/writing the disk). syncq_wait: Amount of time IO spent in synchronous priority queues. Does not include disk time. asyncq_wait: Amount of time IO spent in asynchronous priority queues. Does not include disk time. scrub: Amount of time IO spent in scrub queue. Does not include disk time.
-l
total_wait: Average total IO time (queuing + disk IO time). disk_wait: Average disk IO time (time reading/writing the disk). syncq_wait: Average amount of time IO spent in synchronous priority queues. Does not include disk time. asyncq_wait: Average amount of time IO spent in asynchronous priority queues. Does not include disk time. scrub: Average queuing time in scrub queue. Does not include disk time.
-q
syncq_read/write: Current number of entries in synchronous priority queues. asyncq_read/write: Current number of entries in asynchronous priority queues. scrubq_read: Current number of entries in scrub queue.
All queue statistics are instantaneous measurements of the number of entries in the queues. If you specify an interval, the measurements will be sampled from the end of the interval.
zpool
labelclear
[-f
] device-f
zpool
list
[-HgLpPv
] [-o
property[,property]...]
[-T
u|d]
[pool]... [interval
[count]]-g
-H
-o
property-L
-p
-P
-L
-flag.
-T
u|d-u
for a printed
representation of the internal representation of time. See
time(2). Specify -d
for
standard date format. See date(1).-v
zpool
offline
[-f
] [-t
]
pool device...zpool
online
[-e
] pool
device...-e
zpool
reguid
poolzpool
reopen
poolzpool
remove
pool device...zpool
detach
command. Non-redundant and raidz devices cannot be removed from a
pool.zpool
replace
[-f
] [-o
property=value]
pool device
[new_device]The size of new_device must be greater than or equal to the minimum size of all the devices in a mirror or raidz configuration.
new_device is required if the pool is not redundant. If new_device is not specified, it defaults to old_device. This form of replacement is useful after an existing disk has failed and has been physically replaced. In this case, the new disk may have the same /dev path as the old device, even though it is actually a different disk. ZFS recognizes this.
-f
-o
property=valuezpool
scrub
[-s
| -p
]
pool...zpool
status
command reports the progress of the scrub
and summarizes the results of the scrub upon completion.
Scrubbing and resilvering are very similar operations. The difference is that resilvering only examines data that ZFS knows to be out of date (for example, when attaching a new device to a mirror or replacing an existing device), whereas scrubbing examines all data to discover silent errors due to hardware faults or disk failure.
Because scrubbing and resilvering are I/O-intensive
operations, ZFS only allows one at a time. If a scrub is paused, the
zpool
scrub
resumes it.
If a resilver is in progress, ZFS does not allow a scrub to be started
until the resilver completes.
-s
-p
zpool
scrub
again.zpool
set
property=value
poolzpool
split
[-gLnP
] [-o
property=value]...
[-R
root] pool
newpool [device ...]The optional device specification causes the specified device(s) to be included in the new pool and, should any devices remain unspecified, the last device in each mirror is used as would be by default.
-g
-L
-n
-P
-L
-flag.
-o
property=value-R
rootzpool
status
[-c
[SCRIPT1[,SCRIPT2]...]]
[-gLPvxD
] [-T
u|d] [pool]...
[interval [count]]If a scrub or resilver is in progress, this command reports the percentage done and the estimated time to completion. Both of these are only approximate, because the amount of data in the pool and the other workloads on the system can change.
-c
[SCRIPT1[,SCRIPT2]...]zpool
status
output. See the
-c
option of zpool
iostat
for complete details.-g
-L
-P
-L
-flag.
-D
-T
u|d-u
for a printed
representation of the internal representation of time. See
time(2). Specify -d
for
standard date format. See date(1).-v
-x
zpool
sync
[pool ...]zpool
upgrade
zpool
upgrade
-a
to enable all features on all pools.zpool
upgrade
-v
zpool
upgrade
[-V
version]
-a
|pool...The following exit values are returned:
# zpool create tank raidz sda sdb sdc sdd sde sdf
# zpool create tank mirror sda sdb mirror sdc sdd
# zpool create tank sda1 sdb2
# zpool create tank /path/to/file/a /path/to/file/b
# zpool add tank mirror sda sdb
# zpool list NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT rpool 19.9G 8.43G 11.4G - 33% 42% 1.00x ONLINE - tank 61.5G 20.0G 41.5G - 48% 32% 1.00x ONLINE - zion - - - - - - - FAULTED -
# zpool destroy -f tank
# zpool export tank
# zpool import pool: tank id: 15451357997522795478 state: ONLINE action: The pool can be imported using its name or numeric identifier. config: tank ONLINE mirror ONLINE sda ONLINE sdb ONLINE # zpool import tank
# zpool upgrade -a This system is currently running ZFS version 2.
# zpool create tank mirror sda sdb spare sdc
If one of the disks were to fail, the pool would be reduced to the degraded state. The failed device can be replaced using the following command:
# zpool replace tank sda sdd
Once the data has been resilvered, the spare is automatically removed and is made available for use should another device fails. The hot spare can be permanently removed from the pool using the following command:
# zpool remove tank sdc
# zpool create pool mirror sda sdb mirror sdc sdd log mirror \ sde sdf
# zpool add pool cache sdc sdd
Once added, the cache devices gradually fill with content from
main memory. Depending on the size of your cache devices, it could take
over an hour for them to fill. Capacity and reads can be monitored using
the iostat
option as follows:
# zpool iostat -v pool 5
pool: tank state: ONLINE scrub: none requested config: NAME STATE READ WRITE CKSUM tank ONLINE 0 0 0 mirror-0 ONLINE 0 0 0 sda ONLINE 0 0 0 sdb ONLINE 0 0 0 mirror-1 ONLINE 0 0 0 sdc ONLINE 0 0 0 sdd ONLINE 0 0 0 logs mirror-2 ONLINE 0 0 0 sde ONLINE 0 0 0 sdf ONLINE 0 0 0
The command to remove the mirrored log mirror-2 is:
# zpool remove tank mirror-2
# zpool list -v data NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT data 23.9G 14.6G 9.30G - 48% 61% 1.00x ONLINE - raidz1 23.9G 14.6G 9.30G - 48% sda - - - - - sdb - - - 10G - sdc - - - - -
zpool
status
and zpool
iostat
output with -c
option.
# zpool status -c vendor,model,size NAME STATE READ WRITE CKSUM vendor model size tank ONLINE 0 0 0 mirror-0 ONLINE 0 0 0 U1 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U10 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U11 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U12 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U13 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T U14 ONLINE 0 0 0 SEAGATE ST8000NM0075 7.3T # zpool iostat -vc slaves capacity operations bandwidth pool alloc free read write read write slaves ---------- ----- ----- ----- ----- ----- ----- --------- tank 20.4G 7.23T 26 152 20.7M 21.6M mirror 20.4G 7.23T 26 152 20.7M 21.6M U1 - - 0 31 1.46K 20.6M sdb sdff U10 - - 0 1 3.77K 13.3K sdas sdgw U11 - - 0 1 288K 13.3K sdat sdgx U12 - - 0 1 78.4K 13.3K sdau sdgy U13 - - 0 1 128K 13.3K sdav sdgz U14 - - 0 1 63.2K 13.3K sdfk sdg
ZFS_ABORT
zpool
to dump core on exit for the purposes
of runningZPOOL_IMPORT_PATH
zpool
looks for device nodes and files. Similar to the
-d
option in zpool
import
.ZPOOL_VDEV_NAME_GUID
zpool subcommands to output vdev guids by default.
This behavior
is identical to the zpool status
-g
command line option.ZPOOL_VDEV_NAME_FOLLOW_LINKS
zpool
subcommands to follow links for vdev
names by default. This behavior is identical to the zpool
status -L
command line option.ZPOOL_VDEV_NAME_PATH
zpool
subcommands to output full vdev path
names by default. This behavior is identical to the zpool
status -p
command line option.ZFS_VDEV_DEVID_OPT_OUT
For example, a pool that originated on illumos platform would
have a devid value in the config and zpool
status
would fail when listing the config. This would also be
true for future Linux based pools.
A pool can be stripped of any devid values
on import or prevented from adding them on zpool
create
or zpool add
by setting
ZFS_VDEV_DEVID_OPT_OUT.
ZPOOL_SCRIPTS_AS_ROOT
zpool
status/iostat
with the -c
option. Normally,
only unprivileged users are allowed to run
-c
.ZPOOL_SCRIPTS_PATH
zpool
status/iostat
with the -c
option. This is a
colon-separated list of directories and overrides the default
~/.zpool.d and
/etc/zfs/zpool.d search paths.ZPOOL_SCRIPTS_ENABLED
zpool status/iostat
with the
-c
option. If
ZPOOL_SCRIPTS_ENABLED is not set, it is assumed that the
user is allowed to run zpool status/iostat
-c
.zed(8), zfs(8), zfs-events(5), zfs-module-parameters(5), zpool-features(5)
April 27, 2018 | Linux |