MODULE_PNP_INFO(9) | Kernel Developer's Manual | MODULE_PNP_INFO(9) |
MODULE_PNP_INFO
—
register plug and play information for device
matching
#include
<sys/module.h>
MODULE_PNP_INFO
(const char
*descriptor_string, bus,
module, void *table,
size_t num_entries);
The
MODULE_PNP_INFO
()
macro registers a table of device-identifying data for
use by devmatch(8). Since it is built off module marking
macros, it must follow a DRIVER_MODULE(9) line.
The macro takes a descriptor_string that describes the memory layout of table entries. The string is a series of members separated by semi-colons. Members are identified by a type and a name. They are encoded in the descriptor string by concatenating the type with a colon, followed by the name. (The special type W32 represents two members. The first name is encoded like any other type. The second name is encoded by appending a forward slash and the second name after the first.)
Types are one of the following:
The pseudo-name “#” is reserved for fields that should be ignored. Any member that does not match the parent device's pnpinfo output must be ignored.
The bus parameter is an unquoted word naming the parent bus of the driver. For example, “pci”.
The module parameter is also an unquoted word. It must be unique to the driver. Usually the driver's name is used.
The table parameter points to the device matching data with entries matching the descriptor_string.
The num_entries parameter is the number of
entries in the table, i.e.,
‘nitems(table)
’. Note that only valid
entries should be included. If the table contains trailing zero or bogus
values, they should not be included in
num_entries.
The following example shows usage of W32 type when vendor/device values are combined into single uint32_t value:
#include <sys/param.h> #include <sys/module.h> static struct my_pciids { uint32_t devid; const char *desc; } my_ids[] = { { 0x12345678, "Foo bar" }, { 0x9abcdef0, "Baz fizz" }, }; MODULE_PNP_INFO("W32:vendor/device;D:#", pci, my_driver, my_ids, nitems(my_ids));
The following example shows usage of T type when all entries in the table have the same vendor value:
#include <sys/param.h> #include <sys/module.h> static struct my_pciids { uint16_t device; const char *desc; } my_ids[] = { { 0x9abc, "Foo bar" }, { 0xdef0, "Baz fizz" }, }; MODULE_PNP_INFO("U16:device;D:#;T:vendor=0x1234", pci, my_driver, my_ids, nitems(my_ids));
The macro MODULE_PNP_INFO
appeared in
FreeBSD 11.0.
The PNP framework and devmatch(8) utility were written by Warner Losh <imp@FreeBSD.org>.
October 5, 2018 | Debian |