EFIDEV(4) | Device Drivers Manual | EFIDEV(4) |
efidev
, efirtc
— user-mode access to UEFI runtime
services
To compile this driver into the kernel, place the following lines in your kernel configuration file:
options EFIRT
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
efirt_load="YES"
The driver may be disabled by setting the
loader(8) tunable efi.rt.disabled to
“1
”.
The efidev
device provides user-mode
access to UEFI runtime services. efidev
also
includes a driver to provide a time-of-day clock using the UEFI real time
clock (RTC). However, the RTC may not always be available, based on the UEFI
firmware. If the RTC is not available, it will not be registered as a
time-of-day clock and the time related ioctls below will not be
functional.
efidev
provides the following ioctls
defined in <sys/efiio.h>
with supplemental structures and constants defined in
<sys/efi.h>
:
EFIIOC_GET_TABLE
(struct efi_get_table_ioc)struct efi_get_table_ioc { struct uuid uuid; void *ptr; };
EFIIOC_GET_TIME
(struct efi_tm)struct efi_tm { uint16_t tm_year; uint8_t tm_mon uint8_t tm_mday uint8_t tm_hour; uint8_t tm_min; uint8_t tm_sec; uint8_t __pad1; uint32_t tm_nsec; int16_t tm_tz; uint8_t tm_dst; uint8_t __pad2; };
EFIIOC_SET_TIME
(struct efi_tm)EFIIOC_VAR_GET
(struct efi_var_ioc)EFIIOC_VAR_GET
(struct efi_var_ioc) will also populate the
attrib field.
struct efi_var_ioc { efi_char *name; size_t namesize; struct uuid vendor; uint32_t attrib; void *data; size_t datasize; };
EFIIOC_VAR_NEXT
(struct efi_var_ioc)EFIIOC_VAR_SET
(struct efi_var_ioc)A efidev
device first appeared in
FreeBSD 11.1.
efidev
is currently only available on
amd64 and arm64.
August 12, 2018 | Debian |