GPIO(4) | Device Drivers Manual | GPIO(4) |
gpiobus
— GPIO bus
system
To compile these devices into your kernel and use the device hints, place the following lines in your kernel configuration file:
device gpio
device gpioc
device gpioiic
device gpioled
Additional device entries for the ARM
architecture include:
device a10_gpio
device bcm_gpio
device imx51_gpio
device lpcgpio
device mv_gpio
device ti_gpio
device gpio_avila
device gpio_cambria
device zy7_gpio
device pxagpio
Additional device entries for the MIPS
architecture include:
device ar71xxx_gpio
device octeon_gpio
device rt305_gpio
Additional device entries for the POWERPC
architecture include:
device wiigpio
device macgpio
The gpiobus
system provides a simple
interface to the GPIO pins that are usually available on embedded
architectures and can provide bit banging style devices to the system.
The acronym GPIO
means
“General-Purpose Input/Output.”
The BUS physically consists of multiple pins that can be configured for input/output, IRQ delivery, SDA/SCL iicbus use, etc.
On some embedded architectures (like MIPS), discovery of the bus and configuration of the pins is done via device.hints(5) in the platform's kernel config(5) file.
On some others (like ARM), where FDT(4) is used to describe the device tree, the bus discovery is done via the DTS passed to the kernel, being either statically compiled in, or by a variety of ways where the boot loader (or Open Firmware enabled system) passes the DTS blob to the kernel at boot.
On a device.hints(5) based system these hints
can be used to configure drivers for devices attached to
gpiobus
pins:
gpiobus
where the device is attached. For
example, "gpiobus0". driver and
unit are the driver name and the unit number for the
device driver.gpiobus
that
are connected to the device. The pins will be allocated to the specified
driver instance. Only pins with numbers from 0 to 31 can be specified
using this hint.gpiobus
that are connected to the device. The pins
will be allocated to the specified driver instance. This is a more user
friendly alternative to the pins hint. Additionally,
this hint allows specifying pin numbers greater than 31. The numbers can
be decimal or hexadecimal with 0x prefix. Any non-digit character can be
used as a separator. For example, it can be a comma, a slash or a space.
The separator can be followed by any number of space characters.The following device.hints(5) are only provided
by the ar71xx_gpio
driver:
Simply put, each pin of the GPIO interface is connected to an input/output of some device in a system.
gpioiic(4), gpioled(4), iicbus(4), device.hints(5), gpioctl(8)
The gpiobus
manual page first appeared in
FreeBSD 10.0.
This manual page was written by Sean Bruno <sbruno@FreeBSD.org>.
June 27, 2019 | Debian |