GPIOIIC(4) | Device Drivers Manual | GPIOIIC(4) |
gpioiic
— GPIO I2C
bit-banging device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device gpio
device gpioiic
device iicbb
device iicbus
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
gpioiic_load="YES"
The gpioiic
driver provides an IIC
bit-banging interface using two GPIO pins for the SCL and SDA lines on the
bus.
gpioiic
simulates an open collector kind
of output when managing the pins on the bus, even on systems which don't
directly support configuring gpio pins in that mode. The pins are never
driven to the logical value of '1'. They are driven to '0' or switched to
input mode (Hi-Z/tri-state), and an external pullup resistor pulls the line
to the 1 state unless some other device on the bus is driving it to 0.
On a device.hints(5) based system, such as MIPS,
these values are configurable for gpioiic
:
gpiobus
you are attaching to. Normally just
gpiobus0 on systems with a single bank of gpio pins.gpiobus
that
are to be used for SCLOCK and SDATA from the GPIO IIC bit-banging bus. To
configure pin 0 and 7, use the bitmask of 0b10000001 and convert it to a
hexadecimal value of 0x0081. Please note that this mask should only ever
have two bits set (any other bits - i.e., pins - will be ignored). Because
gpioiic
must be a child of the gpiobus, both gpio
pins must be part of that bus.On an FDT(4) based system, such as ARM, the DTS
node for gpioiic
conforms to the standard bindings
document i2c/i2c-gpio.yaml. The device node typically appears at the root of
the device tree. The following is an example of a
gpioiic
node with one slave device on the IIC
bus:
/ { gpioiic0 { compatible = "i2c-gpio"; pinctrl-names = "default"; pinctrl-0 = <&pinctrl_gpioiic0>; scl-gpios = <&gpio1 5 GPIO_ACTIVE_HIGH>; sda-gpios = <&gpio7 11 GPIO_ACTIVE_HIGH>; status = "okay"; /* One slave device on the i2c bus. */ rtc@51 { compatible="nxp,pcf2127"; reg = <0x51>; status = "okay"; }; }; };
Where:
The gpioiic
manual page first appeared in
FreeBSD 10.1.
This manual page was written by Luiz Otavio O Souza.
December 1, 2019 | Debian |