LINUX(4) | Device Drivers Manual | LINUX(4) |
linux
— Linux ABI
support
To compile support for this ABI into an i386 kernel place the following line in your kernel configuration file:
options COMPAT_LINUX
for an amd64 kernel use:
options
COMPAT_LINUX32
Alternatively, to load the ABI as a module at boot time, place the following line in loader.conf(5):
linux_load="YES"
The linux
module provides limited Linux
ABI (application binary interface) compatibility, making it possible to run
many unmodified Linux applications and libraries without the need for
virtualization or emulation. Some of the facilities provided are:
Note that dynamically linked Linux executables will require a suitable environment in /compat/linux. This includes native Linux shared libraries, and Linux-specific virtual filesystems. To set it up, install the emulators/linux_base-c7 port or the linux_base-c7 package, and add the following line to the rc.conf(5) file:
linux_enable="YES"
To avoid mounting Linux-specific filesystems at startup, also add the following line:
linux_mounts_enable="NO"
The following variables are available as both sysctl(8) variables and loader(8) tunables:
linrdlnk
option, see
fdescfs(5)brandelf(1), pty(4), elf(5), fdescfs(5), linprocfs(5), linsysfs(5), tmpfs(5)
Linux ABI support first appeared in FreeBSD 2.1.
Support for some of the Linux-specific system calls and system call arguments is missing.
July 5, 2020 | Debian |