SYNAPTICS(4) | Device Drivers Manual | SYNAPTICS(4) |
synaptics - touchpad input driver
Section "InputDevice" Identifier "devname" Driver "synaptics" Option "Device" "devpath" Option "Path" "path" ... EndSection
synaptics is an Xorg input driver for touchpads. Even though touchpads can be handled by the normal evdev or mouse drivers, this driver allows more advanced features of the touchpad to become available. Some benefits would be:
Note that depending on the touchpad firmware, some of these features might be available even without using the synaptics driver. Note also that some functions are not available on all touchpad models, because they need support from the touchpad hardware/firmware. (Multifinger taps for example.)
The name "synaptics" is historical and the driver still provides the synaptics protocol parsing code. Under Linux however, the hardware-specifics are handled by the kernel and this driver will work for any touchpad that has a working kernel driver. If your device is recognized as "PS/2 Mouse" or similar, the kernel driver does not support your device and this driver will only provide limited functionality.
Please refer to xorg.conf(5) for general configuration details and for options that can be used with all input drivers. This section only covers configuration details specific to this driver.
The following driver Options are supported:
auto-dev | automatic, default (recommend) |
event | Linux 2.6 kernel events |
psaux | raw device access (Linux 2.4) |
psm | FreeBSD psm driver |
0 | Touchpad is enabled |
1 | Touchpad is switched off (physical clicks still work) |
2 | Only tapping and scrolling is switched off |
0 | All Edges |
1 | Top Edge |
2 | Top Right Corner |
3 | Right Edge |
4 | Bottom Right Corner |
5 | Bottom Edge |
6 | Bottom Left Corner |
7 | Left Edge |
8 | Top Left Corner |
The LeftEdge, RightEdge, TopEdge and BottomEdge parameters are used to define the edge and corner areas of the touchpad. The parameters split the touchpad area in 9 pieces, like this:
LeftEdge | RightEdge | ||
Physical top edge | |||
1 | 2 | 3 | |
TopEdge | |||
4 | 5 | 6 | |
BottomEdge | |||
7 | 8 | 9 | |
Physical bottom edge | |||
Physical left edge | Physical right edge |
Coordinates to the left of LeftEdge are part of the left edge (areas 1, 4 and 7), coordinates to the left of LeftEdge and above TopEdge (area 1) are part of the upper left corner, etc.
A good way to find appropriate edge parameters is to use evtest(1) on the device to see the x/y coordinates corresponding to different positions on the touchpad.
The perceived physical edges may be adjusted with the AreaLeftEdge, AreaRightEdge, AreaTopEdge, and AreaBottomEdge options. If these values are set to something other than the physical edges, input that starts in the space between the area edge and the respective physical edge is ignored. Note that this reduces the available space on the touchpad to start motions in.
A tap event happens when the finger is touched and released in a time interval shorter than MaxTapTime, and the touch and release coordinates are less than MaxTapMove units apart. A "touch" event happens when the Z value goes above FingerHigh, and an "untouch" event happens when the Z value goes below FingerLow.
The MaxDoubleTapTime parameter has the same function as the MaxTapTime parameter, but for the second, third, etc tap in a tap sequence. If you can't perform double clicks fast enough (for example, xmms depends on fast double clicks), try reducing this parameter. If you can't get word selection to work in xterm (ie button down, button up, button down, move mouse), try increasing this parameter.
The ClickTime parameter controls the delay between the button down and button up X events generated in response to a tap event. A too long value can cause undesirable autorepeat in scroll bars and a too small value means that visual feedback from the gui application you are interacting with is harder to see.
The MinSpeed, MaxSpeed and AccelFactor parameters control the pointer motion speed. The speed value defines the scaling between touchpad coordinates and screen coordinates. When moving the finger very slowly, the MinSpeed value is used, when moving very fast the MaxSpeed value is used. When moving the finger at moderate speed, you get a pointer motion speed somewhere between MinSpeed and MaxSpeed. If you don't want any acceleration, set MinSpeed and MaxSpeed to the same value.
The MinSpeed, MaxSpeed and AccelFactor parameters don't have any effect on scrolling speed. Scrolling speed is determined solely from the VertScrollDelta and HorizScrollDelta parameters. To invert the direction of vertical or horizontal scrolling, set VertScrollDelta or HorizScrollDelta to a negative value.
Acceleration is mostly handled outside the driver, thus the driver will translate MinSpeed into constant deceleration and adapt MaxSpeed at startup time. This ensures you can user the other acceleration profiles, albeit without pressure motion. However the numbers at runtime will likely be different from any options you may have set.
When pressure motion is activated, the cursor motion speed depends on the pressure exerted on the touchpad (the more pressure exerted on the touchpad, the faster the pointer). More precisely the speed is first calculated according to MinSpeed, MaxSpeed and AccelFactor, and then is multiplied by a sensitivity factor.
The sensitivity factor can be adjusted using the PressureMotion parameters. If the pressure is below PressureMotionMinZ, PressureMotionMinFactor is used, and if the pressure is greater than PressureMotionMaxZ, PressureMotionMaxFactor is used. For a pressure value between PressureMotionMinZ and PressureMotionMaxZ, the factor is increased linearly.
Since most synaptics touchpad models don't have a button that corresponds to the middle button on a mouse, the driver can emulate middle mouse button events. If you press both the left and right mouse buttons at almost the same time (no more than EmulateMidButtonTime milliseconds apart) the driver generates a middle mouse button event.
Circular scrolling acts like a scrolling wheel on the touchpad. Scrolling is engaged when a drag starts in the given CircScrollTrigger region, which can be all edges, a particular side, or a particular corner. Once scrolling is engaged, moving your finger in clockwise circles around the center of the touchpad will generate scroll down events and counter clockwise motion will generate scroll up events. Lifting your finger will disengage circular scrolling. Use tight circles near the center of the pad for fast scrolling and large circles for better control. When used together with vertical scrolling, hitting the upper or lower right corner will seamlessly switch over from vertical to circular scrolling.
Coasting is enabled by setting the CoastingSpeed parameter to a non-zero value. Coasting comes in two flavors: conventional (finger off) coasting, and corner (finger on) coasting.
Conventional coasting is enabled when coasting is enabled, and CornerCoasting is set to false. When conventional coasting is enabled, horizontal/vertical scrolling can continue after the finger is released from the lower/right edge of the touchpad. The driver computes the scrolling speed corresponding to the finger speed immediately before the finger leaves the touchpad. If this scrolling speed is larger than the CoastingSpeed parameter (measured in scroll events per second), the scrolling will continue with the same speed in the same direction until the finger touches the touchpad again.
Corner coasting is enabled when coasting is enabled, and CornerCoasting is set to true. When corner coasting is enabled, edge scrolling can continue as long as the finger stays in a corner. Coasting begins when the finger enters the corner, and continues until the finger leaves the corner. CornerCoasting takes precedence over the seamless switch from edge scrolling to circular scrolling. That is, if CornerCoasting is active, scrolling will stop, and circular scrolling will not start, when the finger leaves the corner.
The synaptics has a built-in noise cancellation based on hysteresis. This means that incoming coordinates actually shift a box of predefined dimensions such that it covers the incoming coordinate, and only the boxes own center is used as input. Obviously, the smaller the box the better, but the likelihood of noise motion coming through also increases.
A click pad device has button(s) integrated into the touchpad surface. The user must press downward on the touchpad in order to generated a button press. ClickPad support is enabled if the option ClickPad is set or the property is set at runtime. On some platforms, this option will be set automatically if the kernel detects a matching device. On Linux, the device must have the INPUT_PROP_BUTTONPAD property set.
ClickPads do not support middle mouse button emulation. If enabling ClickPad support at runime, the user must also set the middle mouse button timeout to 0. If auto-detected, middle mouse button emulation is disabled by the driver.
ClickPads provide software emulated buttons through Option "SoftButtonAreas". These buttons enable areas on the touchpad to perform as right or middle mouse button. When the user performs a click within a defined soft button area, a right or middle click is performed.
Some laptops, most notably the Lenovo T440, T540 and x240 series, provide a pointing stick without physical buttons. On those laptops, the top of the touchpad acts as software-emulated button area. This area can be enabled with Option "HasSecondarySoftButtons" and configured with Option "SecondarySoftButtonAreas". On some platforms, this option will be set automatically if the kernel detects a matching device. On Linux, the device must have the INPUT_PROP_TOPBUTTONPAD property set.
Synaptics 1.0 and higher support input device properties if the driver is running on X server 1.6 or higher. The synclient tool shipped with synaptics version 1.1 uses input device properties by default. Properties supported:
32 bit, 4 values, left, right, top, bottom. 0 disables an element.
32 bit, 8 values, RBL, RBR, RBT, RBB, MBL, MBR, MBT, MBB.
8 bit (BOOL), 7 values (read-only), has left button, has middle button, has right button, two-finger detection, three-finger detection, pressure detection, and finger/palm width detection.
Configuration through InputClass sections is recommended in X servers 1.8 and later. See xorg.conf.d(5) for more details. An example xorg.conf.d snippet is provided in ${sourcecode}/conf/70-synaptics.conf
Configuration through hal fdi files is recommended in X servers 1.5, 1.6 and 1.7. An example hal policy file is provided in ${sourcecode}/conf/11-x11-synaptics.fdi
If either of Protocol "auto-dev" (default) or Protocol "event" is used, the driver initializes defaults based on the capabilities reported by the kernel driver. Acceleration, edges and resolution are based on the dimensions reported by the kernel. If the kernel reports multi-finger detection, two-finger vertical scrolling is enabled, horizontal two-finger scrolling is disabled and edge scrolling is disabled. If no multi-finger capabilities are reported, edge scrolling is enabled for both horizontal and vertical scrolling. Tapping is disabled by default for touchpads with one or more physical buttons. To enable it you need to map tap actions to buttons. See the "TapButton1", "TapButton2" and "TapButton3" options.
Button mapping for physical buttons is handled in the server. If the device is switched to left-handed (an in-server mapping of physical buttons 1, 2, 3 to the logical buttons 3, 2, 1, respectively), both physical and TapButtons are affected. To counteract this, the TapButtons need to be set up in reverse order (TapButton1=3, TapButton2=1).
The following options are no longer part of the driver configuration:
Peter Osterlund <petero2@telia.com> and many others.
Xorg(1), xorg.conf(5), Xserver(1), X(7), synclient(1), syndaemon(1)
xf86-input-synaptics 1.9.2 | X Version 11 |